Getting Started with Kicad

rev 022421

(Note: the terms folder and directory are synonyms. This document uses directory)

FIRST step Create a directory where you wish to place your design
Second step Install a WWU library of components to be used for this class

Download file aawwu_1ib21.tar from the class webpage into your new project

directory.

Open a terminal window and navigate to your project directory.
Type in this command: tar -xf aawwu_lib21.tar

This will unpack the library files into your project directory.

Start Kicad

Electronics > Kicad (This may vary depending on the window manager in use)

The project manager window will open and look something like this (if you have used Kicad

before it may look different and it may display the name of the prior project)
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To proceed, you can use the File menu to start a new project.

Create a project.
File > New Project > New Project
A new window will open.

Navigate to the directory you created for your design and fill in a name for the project.
In the lower left of the window is a little box asking if you wish to create a directory for the
project. Uncheck that box since you have already created the directory for the project.

A warning message about not creating a directory may appear. That is ok.



The project manager window will then look something like this. The project file ends in .pro
extension.
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On the Project Manager window there are 8 large icons above where the project name is
displayed. These are buttons that will launch a respective tool (place cursor over icon to see tool
name):

schematic layout editor (eeschema)

library layout editor

PCB layout editor (pcbnew)

footprint library editor

gerbview - gerber file viewer

bitmap to component - file convertor

pcb calculator

worksheet layout editor

The next thing to do is to click Preferences on the tool bar and from the drop-down menu select
Manage Symbol Libraries

A Libraries by Scope window will open (see the next page).



Click on the Project Specific Libraries tab

Libraries by Scope /
Global Libraries Project Specific Libraries

File: /home/larmy.aamodt/ee3s5/kicadsdemo3fsym-lib-table
Active Nickname Library Path Plugin Type Options Description

File browser button

l

. o0 5 o &
Path Substitutions:
Name

${KICAD_SYMBOL DIR} /usrjshare/kicad/library
${KIPRJMOD} /home/larry.aamodt/ee355/kicad5demo3

Value

& Cancel

= OK

Then click the button at lower left between the + and up-arrow buttons. This is the file browser

button.

A Select Library window will open. It should show your project directory, but if needed,
navigate to your project directory. You should see the file aawwu.lib

Click on aawwu.lib to highlight it. Then click Open

The aawwu.lib file should now appear in the Libraries by Scope window.

Click on OK to close the libraries window




Next, again click Preferences on the tool bar and from the drop-down menu select
Manage Footprint Libraries

A footprint Libraries by Scope window will open

Click on the Project Specific Libraries tab.

Footprint Libraries

Libraries by Scope
Global Libraries Project Specific Libraries
File: /home/larry.aamodtfee355/wtr20/project/pcbl/fp-lib-table
Active Nickname Library Path Plugin Type Options Description
S e e &
Path Substitutions:
Name Value
${KIPRJMOD} /homejlarry.aamodtfee355/wtr20/project/pcbl
${KISYS3DMOD} Jusrfshare/kicad/modules/packages3d/
£ {KISYSMOD} Jusrfshare/kicad/modules
& Cancel @ 0K

Then click the button at lower left between the + and up-arrow buttons. This is the file browser
button.

A Select Library window will open. It should show your project directory, but if needed,
navigate to your project directory. You should see the directory (folder) aawwu.pretty

Click on aawwu.pretty to highlight it. Then click Open
The aawwu.pretty directory should now appear in the Libraries by Scope window.

Click on OK to close the libraries window



Start the schematic layout editor, eeschema, by clicking it’s icon (the left large icon in which a

transistor symbol can be seen). Something like this should appear:
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The default sheet size likely will be A4. That is similar to American size A, 8.5 x 11 inches.
That may be too small, so change the sheet size to B which is 11x17 inches.

Click the button pointed to by the red arrow above
( or Select File > Page Settings on the tool bar)

and the Page Settings window should open as shown on the next page:




[ 4] Page Settings

Paper Title Block Parameters
Size: Number of sheets: 1 Sheet number: 1
| A4 210x297mm 3| IssueDate B
[ ] | <<<]| [01f25f2017 “v| [ Export to other sheets
Orientation: — . ’ —
|‘ Landscape s | Revision
. [ ] [] Export to other sheets
Custom Size: Title
Height: Width: [ ] [] Export to other sheets
Company
Layout Preview [ ] [ Export to other sheets
Commentl
[ ] [ Export to other sheets
Comment2
[ ] [ Export to other sheets
Comment3
[ ] [] Export to other sheets
Comment4
% [ l [] Export to other sheets
Page layout description file
[ l | Browse|
Cancel | | OK |

Size can be set with the drop down menu at upper left. Also, various fields can be filled in with
data that will appear in the title block. Here is what I filled in (your name is required):

4] Page Settings x
Paper Title Block Parameters

Size: Number of sheets: 1 Sheet number: 1
[ B 11x17in s ] Issue Date - o

T [2017-01-25 | [<<<| [01/25/2017 |v| O Export toother sheets
Orientation: - ! —
I‘ ~ | | Revision

Landscape o] |
[1,0 ] [ Export to other sheets

Custom Size: Title
Height: Width: [ENGR-355 Project ] [] Export to other sheets

Company

Layout Preview [Walla Walla University

] [ Export to other sheets

Commentl
[L.Aamodt ] [ Export to other sheets
Comment2
[ ] [0 Export to other sheets
Comment3
[ ] [ Export to other sheets
Comment4

= [ ] [] Export to other sheets

Page layout description file

[

] | Browse |

Cancel | | OK |




To begin placing components on the schematic sheet click the note the tool bar on the right.
There is what appears to be the symbol for an op-amp.

—T——

Click the “op-amp” symbol. —

Then move the cursor over the drawing
area of the sheet and click again.
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A component selection window should open. A list of libraries will be shown.

ra
Q
- Recently Used -
b aawwu
b Device
No symbol selected
Select with Browser X Cancel | | ~OK |

Near the top should be a library named aawwu

Click on aawwu

Clicking on the name of a library will open up a list of the components in that library



A list of the components in a library (once used, recent components will be shown at the top):

S Choose Symbol (72 items loaded) o e
Ay
-- Recently Used --
_I
+3.3V Power symbol creates a global label
+3V3 Power symbol creates a global label
+5V Power symbol creates a global label
25LCxxx SPI Serial EEPROM, DIP-8/SOIC-8/TS¢
No symbol selected
ADSO0IAN
AT25xxX
BR255xxx
C Unpolarized capacitor
CAT250xxx
CP1 Polarised capacitor
Conn_01x01 Generic connector, single row, 01x0
L]
Select with Browser @ Cancel © 0K

Click on a desired component and its symbol will appear in the pane to the right.
Click OK to select this component and enable placing its symbol on the schematic.

A symbol for the component should be linked to the cursor. Move cursor/component to desired
location on the drawing sheet and click to place it.

(NOTE: There may be other libraries in addition to aawwu. For ENGR-355 projects only use
parts from the aawwu library).



There are many hot keys. Get a list by pressing ? A partial list is:

G Hotkeys List x

Hotkeys List 7

Help (this window) ?

Zoom In F1l

Zoom Qut F2

Zoom Redraw F3

Zoom Center Fa4

Fit on Screen Home

Reset Local Coordinates Space

Edit Item E

Delete Item Del -

Rotate Item R

Drag Item G

Undo Ctri+Z

Redo Ctri+Y

Mouse Left Click Return

Mouse Left Double Click End

Save Schematic Ctri+s

Load Schematic Ctri+L

Find Item Ctri+F

Find Next Item F5

Find Next DRC Marker Shift+F5 .

Find and Replace Ctri+Alt+F

Repeat Last Item Ins

Move Block -= Drag Block Tab

Save Block Ctrl+cC

Move Schematic Item M

Copy Component or Label C

Add Component A

Add Power P

Mirror X X

Mirror ¥ Y

Orient Normal Component N

Edit Component Value v

Edit Camnanant Bafaranca (1| IE]
| Close|

Power connections could be made by drawing lines between component pins
that connect to a common power. However, this can make the drawing messy,
particularly for ground connections. So typically we use a ground symbol
anywhere a node connects to ground and typically a power symbol such as
Vdd or Vcc where a node connects to a power source.

After placing needed parts on the schematic, connect wires between them by
clicking on the green line in the right-hand tool bar to select the wiring tool
and clicking starting point and ending point for desired wires.



Project parts
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To summarize, these steps are needed: to create the schematic and prepare for circuit board
layout:
1) Place parts
2) Draw nets
3) Add power/ground symbols
4) Name important nets (Place -> Local Label)
5) Edit title block (File -> Page Settings)
6) Add comment text as appropriate (Place -> Text)
7) Annotate schematic (Tools -> Annotate Schematic)
Annotate means to fill in the sequential number portion of component reference
designators such as R1, R2, U1, U2, etc.
8) Run the Electrical Rule Checker (often referred to as the Design Rule Checker or DRC).
(Tools -> Electrical Rule Checker)
Note: You likely will have one or more errors. More on this below.
9) Associate schematic symbols and footprints for layout. More on that below.
(Tools -> Assign Component Footprints) or edit each symbol and add foot print.
10) Generate a netlist file (Tools -> Generate Netlist File)

Running the electrical rule checker and solving reported errors

4

Start the rule checker from pulldown menu (Tools -> Electrical Rule Checker) or icon

from the upper tool bar. A blank dialog box should open:

Electrical Rules Checker R —
ERC|| Options
ERC Report: Messages:
Total: 0

Warnings: 1]

Errors: o

] Create ERC file report

Error list:

Delete Markers Run | Close

Then click Run to do a rule check. Note that the annotate schematic step needs to be done before
rule checking works.



Here is an example result that shows errors involving power connections:

ERC | Options
ERC Report: N’!E§s:g:s:
Tokal: 3 Finishe

warnings: 3

Errors: ]
|| Create ERC file report
Error list:

ErrType(3): Pin connected to some others pins but no pin to drive it
¢ @ (86.36 mm,83.82 mm): Pin 1 (Power input) of component #PWRO02 is not
driven (Net 7).
ErrType(3): Pin connected to some others pins but no pin to drive it
¢ @ (140.97 mm,109.22 mm): Pin 8 (Power input) of component U3 is not
driven (Net 11).
ErrType(3): Pin connected to some others pins but no pin to drive it
e @ (175.26 mm,71.12 mm): Pin 14 (Power input) of component U4 is not
driven (Net 16).

Delete Markers| | Run | Close

A common error is with power distribution. In the power symbols list there are many choices
such as Vdd, Vcc, +3.3V, +3V3, GND, etc. and you likely have used one or more of these. Some
components such as logic parts, memory parts, op-amps, etc. have power pins that are not
initially visible on the schematic. If the name on a power symbol the schematic doesn’t match the
name used by a component (which may be hidden initially) errors may be reported. By default,
for components such as 74HCxxx or 74LSxxx parts the power pins don’t appear on the
schematic symbol. You can make them visible using the hidden pints icon:

on the left tool bar. Add visible symbols to your power net to match the | :D' ‘

hidden ones on your component symbols. Also, even though the correct symbols are used the
power net(s) need to be identified as such with the following symbol:  FWR_FLAG Place this

symbol on a ground net and your power net. A sample circuit: o ;?;
+3.3V
2 PWRFLAG
Conn_01x02 —

I:i i c?
2 PWR%:LAG HC

GND



Associate schematic symbols with board layout foot prints
Using (Tools -> Assign Component Footprints) or a top tool bar icon open the tool.

Click OK. A window similar to this will open:

Cvpch 4.0.5 Project: 'fhome/larry.aamodt/ee355/demokicad/kicad_demo?2/kicad_demo2.pro'

File Preferences Help

& B e w0

air Coils SML NEOSID |3 1 Capacitors SMD:C 8201 A
Buttons Switches SMD 2 £2:- € 0805 BRIUF : Capacitors SMD:C 0805 2 Capacitors SMD:C 0462 3
Buttons Switches THT 3 c3 - C 0805 BRIuUF : Capacitors SMD:C 0865 3 Capacitors SMD:C 0663

Buzzers Beepers 4 D1 - BAS70 : TO SOT SMD:SO0T-23 4 Capacitors SMD:C 8663 HandSolderi
Capacitors SMD 5 D2 - BA570 : TO 50T SMD:50T-23 pees

Capacitors THT 6 P1 - CONN_©1Xe2 : 6 Capacitors SMD:C 8885 HandSolderi
Capacitors Tantalum SMD 7 P2 - CONN_©1Xe2 : 7 Capacitors SMD:C 1206

Choke Axial ThroughHole 8 P3 - CONN B1X02 : 8 Capacitors SMD:C 1286 HandSolderi
Choke Common-Mode Wurth 9 P4 - CONN_©1Xe8 : 9 Capacitors SMD:C 1210

Choke Radial ThroughHole 10 Rl - R 0885 108K 5PER : Resistors SMD:R 0865 10 Capacitors SMD:C 1210 HandSolderi
Choke SMD 11 m. - TLV3202 : 11 Capacitors SMD:C 1812

Choke Toroid ThroughHole 12 uz - T4HCT74 12 Capacitors SMD:C 1812 HandSolderi
Connectors 13 us - 25LC160C-I/SN : Housings SOIC:SOIC-8 3.9x4.9mm| | 13 Capacitors SMD:C 1825

Connectors Harwin 14 ug - 745088 : 14 Capacitors SMD:C 1825 HandSolderi
Connectors Hirose 15 Capacitors SMD:C 2220

Connectors JAE 16 Capacitors SMD:C 2220 HandSolderi
Connectors JST & 17 Capacitors SMD:C 2225 !
a [ | [<] | ][] | [>)
Components: 14, unassigned: 7 Filter list: C?, C_?777 *, C_?777, SMD*_c, Capacitor* Filtered by key words: 234

The left panel is a list of libraries. The middle panel is a list of components in your design for
which foot prints need to be assigned. The right panel is a list of foot prints found in the selected
library.

Some of your components have foot prints associated with them using information in the symbol
and those foot prints are shown. Click on a component that doesn’t have a foot print yet
associated (i.e. blank to the right of the colon). Then click on the library with the desired foot
print. Scroll through the foot prints and find the correct one. Double click on it to associate with
the highlighted component in the center panel. Do this for all components as needed.

After all components have been associated with a foot print do a save.

Write the netlist
(Tools -> Generate Netlist File; Click Generate) Use defaults as shown in figure below.

s Netlist —+ x| A file called a netlist is used to
Pcbnaw | e e — transfer the design described by the
schematic to the circuit board layout
Options: . . . .
o Default format XCencel | program. This netlist contains a list
erau orma . . .
Add Plugin of the components in the design, a list

of the connections (nets) between
components, and information giving
the physical geometry of the footprint
T e e for each type of component.

kicad_demo2.net

"] Use default netname




(The netlist file written by Kicad is an ASCII file meaning that you can use a text editor to open
it and read the contents if you are curious about what is in it.)

(You don’t need to create the bill of materials today)

Write the Bill of Materials File (BOM file)
(Tools -> Generate Bill of Materials)
The bill of materials file lists the components used, quantity, possibly a supplier part number, etc.

When this tool is invoked it will display a window like this:

/] Bill of Material x
| Close |
| Help |
| Add Plugin |

| Remove Plugin |
Name: P —

[ | |Edit Plugin File|

Command line:

l l

Plugin Info:

A plugin that will write the BOM file in a particular format needs to be added.
Click: Add Plugin and navigate to the folder shown below. Select bom2csv.xsl



